Solar power degradation
Incident Report for Patientco
Resolved
The sun has been brought back online and systems are recovering as expected. Patientco will continue monitoring until solar radiation is back at 100%. Look for our next solar maintenance window on April 8, 2024.
Posted Aug 21, 2017 - 18:43 UTC
Monitoring
The sun is being taken offline for several minutes for planned maintenance. We assure you that Patientco is actively monitoring the situation and will ensure that payment processing is unaffected.
Posted Aug 21, 2017 - 18:09 UTC