Patient Payment - Payment Degradation

Incident Report for Patientco

Resolved

We have confirmed that our payments are now processing without issue. Our testing has confirmed declines have fallen under expected ranges. If you continue to have issues with payment processing, please submit a case through the Support and Training Center for additional investigation.
Posted Jun 12, 2025 - 18:04 EDT

Update

We are currently experiencing issues with one of our Third Party vendors, which is impacting payment processing. As of 2:24pm we have implemented a change on our end that is showing a higher rate of success for payment processing.

We are now seeing payment processing returning to normal, but we will continue to monitor this issue to ensure there are no additional issues.
Posted Jun 12, 2025 - 17:02 EDT

Update

We are currently experiencing issues with one of our Third Party vendors, which is impacting payment processing. As of 2:24pm we have implemented a change on our end that is showing a higher rate of success for payment processing.

We are now seeing payment processing returning to normal, but we will continue to monitor this issue to ensure there are no additional issues.
Posted Jun 12, 2025 - 15:10 EDT

Monitoring

We are currently experiencing issues with one of our Third Party vendors, which is impacting payment processing. As of 2:24pm we have implemented a change on our end that is showing a higher rate of success for payment processing. We will continue to monitor this issue and provide updates as they become available.
Posted Jun 12, 2025 - 14:36 EDT

Investigating

We are currently experiencing issues with one of our Third Party vendors, which is impacting payment processing. At this point, we are seeing some payments still process, but many payments are declining. We are actively working to identify and mitigate the issue and will provide an update once it becomes available.
Posted Jun 12, 2025 - 14:14 EDT
This incident affected: Patient Wallet, Integrated Payments and Payment Processing Status (Credit Card Processing, eCheck Processing, EMV Hardware).